Update 0.3.10
Incident Report for Popcorn Time
Resolved
This incident has been resolved.
Posted 15 days ago. Nov 27, 2017 - 11:27 UTC
Monitoring
Update Available 0.3.10
We have not the infrastructure to host it so please download directly from website https://popcorntime.sh
Thank you ! and Enjoy !

https://github.com/popcorn-official/popcorn-desktop/blob/master/CHANGELOG.md
Posted about 1 year ago. Oct 31, 2016 - 15:07 UTC
This incident affected: Nameservers, Website, Shows API (TVAPI), Movies API, Anime API, and Trakt.tv.