Network outage FR / US
Incident Report for Popcorn Time
Resolved
This incident has been resolved.
Posted about 3 years ago. Nov 12, 2014 - 21:21 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted about 3 years ago. Nov 12, 2014 - 19:22 UTC