Android App
Incident Report for Popcorn Time
Resolved
This incident has been resolved.
Posted almost 3 years ago. Feb 04, 2015 - 10:27 UTC
Identified
Android app issue has been identified and a fix is being implemented
Posted almost 3 years ago. Feb 03, 2015 - 16:09 UTC