Download mirrors experiencing downtime
Incident Report for Popcorn Time
Resolved
Issue Resolved , all back to normal
Posted almost 2 years ago. Oct 11, 2015 - 11:16 UTC
Identified
Some of our download mirrors are experiencing some downtime. We're looking into this, they should be back up as soon as possible.
Posted almost 2 years ago. Oct 11, 2015 - 10:44 UTC